Build Issue with Gantt SharePoint Fabric

Our state of the art Gantt chart


Post Reply
User avatar
spdev
Posts: 2
Joined: Fri Nov 20, 2020 7:45 pm

Build Issue with Gantt SharePoint Fabric

Post by spdev »

Hi,

I am getting the enclosed error (screenshot enclosed). Can you please help? I am trying to build the SharePoint Fabric example using NodeJS

Thanks for your help

Attachments
Error.PNG
Error.PNG (95.33 KiB) Viewed 20 times

User avatar
mats
Core Developer
Core Developer
Posts: 16692
Joined: Sat Dec 19, 2009 11:41 pm
Location: Sweden
Contact:

Re: Build Issue with Gantt SharePoint Fabric

Post by mats »

Did this answer help you? viewtopic.php?p=79544#p79544

Tired of debugging javascript errors in web applications? Try our new error logging service RootCause, or read more on the Sencha blog

@bryntum
Facebook
API documentation

User avatar
Terence
Core Developer
Core Developer
Posts: 1530
Joined: Tue Apr 01, 2014 2:23 pm

Re: Build Issue with Gantt SharePoint Fabric

Post by Terence »

In case the answer above does not help. You can try to copy the gantt.d.ts file instead of linking it in the postinstall. It could be the case that on fat32 systems symlinks are not allowed. But seeing the other post you probably already bypassed this problem.

Code: Select all

postinstall": {
    "node_modules/bryntum-gantt/gantt.d.ts": "copy node_modules/bryntum-gantt/gantt.module.d.ts",

Updated package.json

Code: Select all

{
  "name": "bryntum-fabric-sp-fx",
  "version": "0.0.1",
  "private": true,
  "main": "lib/index.js",
  "engines": {
    "node": ">=0.10.0"
  },
  "scripts": {
    "builder": "node ../../../_shared/scripts/build.js",
    "build": "gulp bundle",
    "clean": "gulp clean",
    "test": "gulp test",
    "preinstall": "npm run builder",
    "postinstall": "postinstall"
  },
  "postinstall": {
    "node_modules/bryntum-gantt/gantt.d.ts": "copy node_modules/bryntum-gantt/gantt.module.d.ts",
    "node_modules/bryntum-gantt/gantt.stockholm.css": "copy src/webparts/bryntumGantt/resources/gantt.stockholm.scss",
    "node_modules/bryntum-gantt/fonts": "copy src/webparts/bryntumGantt/resources/fonts",
    "../../../_datasets/launch-saas.json": "copy src/webparts/bryntumGantt/resources/data/launch-saas.json",
    "node_modules/bryntum-react-shared/resources/images": "copy src/webparts/bryntumGantt/resources/images",
    "node_modules/bryntum-react-shared/src/BryntumGantt.js": "copy src/webparts/bryntumGantt/shared/BryntumGantt.js",
    "node_modules/bryntum-react-shared/src/BryntumWidget.js": "copy src/webparts/bryntumGantt/shared/BryntumWidget.js"
  },
  "dependencies": {
    "@microsoft/sp-core-library": "1.10.0",
    "@microsoft/sp-lodash-subset": "1.10.0",
    "@microsoft/sp-office-ui-fabric-core": "1.10.0",
    "@microsoft/sp-property-pane": "1.10.0",
    "@microsoft/sp-webpart-base": "1.10.0",
    "@pnp/sp": "^2.0.3",
    "@pnp/spfx-property-controls": "1.17.0",
    "@types/es6-promise": "0.0.33",
    "@types/react": "16.8.8",
    "@types/react-dom": "16.8.3",
    "@types/webpack-env": "1.13.1",
    "bryntum-gantt": "file:../../../../build",
    "bryntum-react-shared": "file:../../_shared/build",
    "office-ui-fabric-react": "6.189.2",
    "react": "16.8.5",
    "react-dom": "16.8.5"
  },
  "resolutions": {
    "@types/react": "16.8.8"
  },
  "devDependencies": {
    "@microsoft/rush-stack-compiler-3.3": "0.3.5",
    "@microsoft/sp-build-web": "1.10.0",
    "@microsoft/sp-module-interfaces": "1.10.0",
    "@microsoft/sp-tslint-rules": "1.10.0",
    "@microsoft/sp-webpart-workbench": "1.10.0",
    "@types/chai": "3.4.34",
    "@types/mocha": "2.2.38",
    "ajv": "~5.2.2",
    "gulp": "~3.9.1",
    "postinstall": "~0.4.2",
    "string-replace-loader": "^2.3.0"
  }
}

Hope this will help.


Post Reply