BUG: Refiltering a column in a tree grid fails after no records are found

Our blazing fast Grid component built with pure JavaScript
Post Reply
User avatar
lesterleong
Posts: 4
Joined: Mon May 20, 2019 11:38 pm

BUG: Refiltering a column in a tree grid fails after no records are found

Post by lesterleong » Tue Jun 11, 2019 10:37 pm

There is a bug with filtering columns in tree grids. After filtering a column in a tree grid and getting no results, refiltering for a substring of that value will also fail to return any results even though valid matches exist. If the user completely clears the filter (by hitting 'x' or backspacing all the way), then the filters are reset, and searching for the same substring works, but the user shouldn't have to do this.

This is reproducible in the Bryntum examples themselves:

1. Go to https://www.bryntum.com/examples/grid/tree/
2. Filter airline for "Luf". All the Lufthansa rows should be returned.
3. Filter airline for "Luff". There should now be no results.
4. Filter airline for "Luf" again. No results appear, even though we know there are matching rows.

Note: this seems to only be a bug with tree grids - normal grids work fine. Doing a similar test on https://www.bryntum.com/examples/grid/filterbar/ works fine.

User avatar
mats
Core Developer
Core Developer
Posts: 14131
Joined: Sat Dec 19, 2009 11:41 pm
Location: Sweden
Contact:

Re: BUG: Refiltering a column in a tree grid fails after no records are found

Post by mats » Wed Jun 12, 2019 10:39 am

Tired of debugging javascript errors in web applications? Try our new error logging service RootCause, or read more on the Sencha blog

@bryntum
Facebook
API documentation

Post Reply