How to switch between EXTJS versions?

Ask our community for help with v1.x versions of our products.
Post Reply
User avatar
lobocroiden
Posts: 74
Joined: Mon Jun 30, 2014 11:13 am

How to switch between EXTJS versions?

Post by lobocroiden » Thu Aug 07, 2014 8:00 am

Hi,

We use our own platform , where EXTJS 3.2 library loads by default in the page. But here to use gantt or scheduler we require EXT 4.2 library. because of this both EXTJS versions are conflicting. Please let us know if there is any way to choose specific version of EXTJS in the loaded libraries?

Thanks.

User avatar
mats
Core Developer
Core Developer
Posts: 15590
Joined: Sat Dec 19, 2009 11:41 pm
Location: Sweden
Contact:

Re: How to switch between EXTJS versions?

Post by mats » Thu Aug 07, 2014 8:07 pm

Not really, I'd recommend to use iframes to make sure there are no conflicts. Or use the Ext JS sandboxing feature.

http://stackoverflow.com/questions/9364 ... js-sandbox
Tired of debugging javascript errors in web applications? Try our new error logging service RootCause, or read more on the Sencha blog

@bryntum
Facebook
API documentation

User avatar
lobocroiden
Posts: 74
Joined: Mon Jun 30, 2014 11:13 am

Re: How to switch between EXTJS versions?

Post by lobocroiden » Fri Aug 08, 2014 8:32 am

During implementation of ExtJs Sandbox, Can we modified the Bryntum library code?

User avatar
Maxim Gorkovsky
Core Developer
Core Developer
Posts: 3060
Joined: Wed Jan 08, 2014 11:46 am

Re: How to switch between EXTJS versions?

Post by Maxim Gorkovsky » Fri Aug 08, 2014 1:03 pm

I'm sorry, I don't understand. Can you elaborate?

User avatar
lobocroiden
Posts: 74
Joined: Mon Jun 30, 2014 11:13 am

Re: How to switch between EXTJS versions?

Post by lobocroiden » Fri Aug 08, 2014 1:40 pm

In the above comment it was told to use Extjs Sanboxing feature. During this implementation, do we require any change in the Bryntum library code?

Post Reply