Get help with testing, discuss unit testing strategies etc.

Post by nickolay »

unfortunately, it did not work out

This is strange, because neither the Siesta code for code coverage, not nyc version has changed between the 5.5.0 and 5.5.1. Can you please double check? Note, that when using --nyc.include need to use the equation character: --nyc.include=glob_pattern

Post by Hakim »

Hi there,
I need to come back to this thread again

From the api documentation I can see this :

I just feel that the cmd


does not do anything and decide to run

npx nyc --help

in Siesta folder to better understand of course with the help of doc.
Here is the complaint I get Image.
It seems that it looks for a module called


which is not there indeed.
what might be the cause?

Last edited by Hakim on Fri Oct 23, 2020 10:56 am, edited 1 time in total.

Post by nickolay »


Thanks for the report, reproduced in the package (works in my development environment). I'll investigate and let you know.

Post by Hakim »


Post by Hakim »

Good news!
I aliased my localhost to something else as suggested in documentation: Image.
Now, I could generate the report fully. I did not apply that workaround because I run tests using


and thought that the issue is only with



Here is the caption : Image
Thanks for your support!

Post by nickolay »

Glad you solved it, yw!

Post Reply