Microsoft EDGE fails to load when starting it from command prompt

Get help with testing, discuss unit testing strategies etc.
Post Reply
User avatar
jenserik
Posts: 1
Joined: Wed Sep 11, 2019 1:55 pm

Microsoft EDGE fails to load when starting it from command prompt

Post by jenserik » Wed Sep 11, 2019 3:10 pm

We have been using Siesta test script for a while now but have mainly been focused on testing our web application using Chrome and Firefox browsers - but we also want to execute them using Microsoft EDGE.
We have downloaded the latest Siesta version (5.2.3) and have executed all our scripts using the Siesta GUI (in EDGE) without any problems - but when trying to execute them using command prompt it fails with the following error:
[ERROR] Setup failed: Error: Can't create first page, runner: a Siesta.Launcher.Runner.WebDriverNodeJS, exception: InvalidArgumentError: The specified arguments passed to the command are invalid.

The command is: c:\user\siesta-5.2.3\bin\webdriver https://www.bryntum.com/examples/siesta/browser/ --browser=edge --rerun-failed --browser-arg disable-web-security (here replaced with your example url).
Using --browser=chrome or firefox works fine (using our own application url).

OS is Windows 10 Enterprise (build 18362.295), Microsoft Edge 44.18362.267.0 (EdgeHTML 18.18362) and EDGE webdriver (MicrosoftWebDriver.exe) is version 10.0.18362.1 and the web driver have been verified working using Python script making almost the same call as Siesta does - so maybe we should use Python in the future :-)

Hope you have a good solution to this problem ..
Tack så mycket - vänliga hälsningar
Jens-Erik

User avatar
nickolay
Core Developer
Core Developer
Posts: 3349
Joined: Mon May 16, 2011 10:48 am

Re: Microsoft EDGE fails to load when starting it from command prompt

Post by nickolay » Wed Sep 11, 2019 3:16 pm

Thanks for the report, we'll investigate shortly.
We offer training in both Ext JS and our products, read more here.
Read the API documentation

User avatar
nickolay
Core Developer
Core Developer
Posts: 3349
Joined: Mon May 16, 2011 10:48 am

Re: Microsoft EDGE fails to load when starting it from command prompt

Post by nickolay » Wed Sep 11, 2019 7:05 pm

Confirmed, investigating further.
We offer training in both Ext JS and our products, read more here.
Read the API documentation

Post Reply