Search found 901 matches

This is what you're looking for:

  features: {
    taskDrag: {
      validatorFn(records) {
        const isValid = records[0].color === '#303331';
        // ... etc.

The correct function signature is to be found in docs:

In this case, checking the checkbox selects the corresponding row so you can listen to event. The handler receives all data you may need. We have a React demo where we listen to this event. It's a Grid demo but the ap...

Hello Piotr,

we need a showcase that we can run, investigate and debug. Please prepare and post one. We had previously some troubles with some combinations of angular options and we need to analyze your case.

The key would be to put in a bit more in taskDrag feature where you would specify which would decide about draggability of events. We have an example of that for Scheduler: He...
I have tried to put all build files in basic example directory and it worked. I have created bryntum subdirectory to keep the thing separate and I've put all dependencies there. The resulting folder structure is: Screen Shot 2021-02-26 at 19.02.11.png I'm attaching zip with the modified basic react ...
If the issue resolved by replacing symlink with the actual folder then check if you have "preserveSymlinks":true in angular.json "architect": { "build": { "builder": "@angular-devkit/build-angular:browser", "options": { "preserveSymlinks": true, <=== this line
We would need a showcase that we can run, investigate and debug to know the reason for that specific error you're getting. However, the approach seems to be too complicated because you need to take care of the order of stores for load and commit. We already have methods for handling the data of whol...
Check please our online docs on how to access the scheduler instance: (Section 6. The native Bryntum Scheduler instance) If that does not help then post please a runnable showcase so that we can sor...

Try this:

@beforecelleditstart = "onBeforeCellEditStart"

onBeforeCellEditStart(event) {

It worked for me. The problem is that Vue events are case sensitive and the event fired is all lowercase.

You can try it on-line in Open the code editor and add the following in the list of features:

eventEdit : {
    readOnly : true
Screen Shot 2021-02-22 at 09.58.06.png
Screen Shot 2021-02-22 at 09.58.06.png (560.21 KiB) Viewed 4 times